Okay
  Public Ticket #2176326
Uku Theme zeigt PHP-Fehler
Open

Comments

  • Tom Weber started the conversation

    Hi,

    ich habe Wordpress lokal in Xampp installiert, das Uku-Theme gekauft und ebenfalls installiert. Nach Aktivieren des Themes zeigen Website und Backend folgende PHP-Fehler:

    Deprecated: Function create_function() is deprecated in /Applications/XAMPP/xamppfiles/htdocs/weber/weber-shop/src/wordpress/wp-content/themes/uku/woocommerce/woocommerce.php on line 100

    Deprecated: Function create_function() is deprecated in /Applications/XAMPP/xamppfiles/htdocs/weber/weber-shop/src/wordpress/wp-content/themes/uku/woocommerce/woocommerce.php on line 198

    Deprecated: Function create_function() is deprecated in /Applications/XAMPP/xamppfiles/htdocs/weber/weber-shop/src/wordpress/wp-content/themes/uku/woocommerce/woocommerce.php on line 199

    Deprecated: Function create_function() is deprecated in /Applications/XAMPP/xamppfiles/htdocs/weber/weber-shop/src/wordpress/wp-content/themes/uku/woocommerce/woocommerce.php on line 201

    Deprecated: Function create_function() is deprecated in /Applications/XAMPP/xamppfiles/htdocs/weber/weber-shop/src/wordpress/wp-content/themes/uku/woocommerce/woocommerce.php on line 202

    Deprecated: Function create_function() is deprecated in /Applications/XAMPP/xamppfiles/htdocs/weber/weber-shop/src/wordpress/wp-content/themes/uku/woocommerce/woocommerce.php on line 204

    Deprecated: Function create_function() is deprecated in /Applications/XAMPP/xamppfiles/htdocs/weber/weber-shop/src/wordpress/wp-content/themes/uku/woocommerce/woocommerce.php on line 205
    Notice: Trying to get property 'comment_status' of non-object in /Applications/XAMPP/xamppfiles/htdocs/weber/weber-shop/src/wordpress/wp-includes/comment-template.php on line 1221
    class="archive post-type-archive post-type-archive-product logged-in theme-uku woocommerce woocommerce-page woocommerce-no-js uku-standard blog-default offcanvas-widgets-off">
    weber

    Woocommerce ist installiert und aktiviert. PHP-Version ist 7.3.9.

    Eine Idee, woher die Fehler kommen?

    Danke & Grüße,

    Tom

  •  892
    Marc replied

    Hallo Tom,

    es handelt sich hierbei lediglich um Hinweise zum in Uku verwendeten Code, welcher in einer zukünftigen PHP-Version nicht mehr funktionieren wird. Wir arbeiten bereits an einem entsprechenden Theme-Update. Diese Funktionen sollten aber mit deiner PHP-Version weiterhin problemlos funktionieren.

    Viele Grüße
    Marc

  • Tom Weber replied

    Hallo Marc, danke für die schnelle Antwort. Wenn ich WP_DEBUG ausschalte, werden die Meldungen nicht mehr angezeigt. Wenn das Theme trotz der Warnungen korrekt arbeitet ist alles in Ordnung.

    Ich habe noch zwei weiter Fragen zum Theme. Ich hätte das Theme gerne im Ruapuke-Style, wie kann ich das einsztellen? Und wie kann ich die Demoinhalte runterladen?

    Viele Grüße,

    Tom

  • Tom Weber replied

    Hi Marc,

    habe das über die Suche hier im Forum selbst rausgefunden. Es wäre hilfreich, wenn man sich die Info über den Import der Demodaten nicht selbst suchen müsste, sondern mit dem Theme eine kurze Anleitung ausgeliefert würde.

    Beim Start des Imports der Demodaten wird die Meldung gezeigt, dass das Plugin WP Instagram Widget installiert sein sollte. Dieses wurde seit zwei Jahren nicht mehr aktualisiert und ist aktuell auch nicht mehr runterladbar. Siehe dazu die Seite des Plugins:

    "This plugin has been closed as of August 8, 2019 and is not available for download. Reason: Licensing/Trademark Violation."

    PHP Fehler, fehlende Infos, Verwendung eingestellter Plugins -  Ihr solltet auf jeden Fall so bald wie möglich ein Update des Uku-Themes bereitstellen.

    Abgesehen davon kann das Ticket geschlossen werden.

  •  892
    Marc replied

    Hallo Tom,

    vielen Dank für das Feedback. Wir arbeiten bereits daran und werden die von dir genannten Punkte berücksichtigen.

    Viele Grüße
    Marc