Okay
  Public Ticket #2167166
Page not displaying properly on tablet
Closed

Comments

  • Isabel Lambourne started the conversation

    Hi

    When I add elements - covers and galleries (Jetpack) as blocks on my site landing page - they preview fine on a desktop Mac, but they don't load properly on a tablet. Please could you check on this page. https://isabel-lambourne.co.uk and let me know if this is allowed in the theme.

    It loads ok on a Mac but on a tablet the 2 image gallery covers the header, which is a shame because I had a nice gallery before with 4 columns and 4 rows. It displayed fine on desktop Mac but not on tablet.

    I cannot introduce any widgets except menus in on my landing page with the widgets - I would have liked to feature several quotes and galleries.

    On this test page https://isabel-lambourne.co.uk/wp-admin/customize.php?return=%2Fwp-admin%2Fwidgets.php I can get the Weta Quote widget to appear although the quotes appear together although I entered one in the full width centre and one in the full width bottom.  I entered a gallery with the gallery widget, which does appear but not formatted correctly. It is small and to the left. 

    I have also entered a Jetpack gallery with the Gutenberg gallery and have a gallery which is 4 columns by 4 rows, this shows up in the Wordpress edit window but it doesn't appear on either a desktop Mac or a tablet.

    Are these things allowed in the theme?

    I am trying to stick within what is allowed In the theme, not bend the rules of the theme so that it doesn't work properly. However, unlike in the Weta demo, I don't seem to be able to get row after row of content, which is what I want. 

    I can get the products to show up which I'm grateful for. The header and footers seem to be working correctly.

    Please can you help?

    Best regards,

    Isabel

  • Isabel Lambourne replied

    Hi, this is an update. I tested the site on a newer tablet device and it resolved lots of the issues. The remaining issues are:

    - although I can create Weta Quote areas in any of the widget areas now on a sub page based on the 'Front Page' template, weirdly I cannot create them on the landing page itself.

    - Furthermore the gallery I create from the widget area is still small and to the side even though it is placed in full width  - see test page 3 here https://isabel-lambourne.co.uk/wp-admin/customize.php?return=%2Fwp-admin%2Fwidgets.php

    - Also, Jetpack gallery of 4x4 images doesn't show up at all.

    These are issues as I would like to have quite a few rows of different content on some pages.

    Please let me know if there are settings I have not applied properly.

    Best regards

    Isabel

  •  955
    Marc replied

    Hi Isabel,

    the Weta Quote widget can only be used using the "Front Page" template, so you'd need to use a page with this template as actual front page to use it there.

    Unfortunately I'm not able to view your test page, since I don't have a user account in your WordPress installation. You can create a temporary admin user for me and send username and password in an as private marked message. If you want to use my email address for this user, you can use wordpress@marcjandt.de

    Taking a direct look at your dashboard will clear things up, so I can tell you more about the issues.

    Best,
    Marc

  • Isabel Lambourne replied

    hi Mark,

    hi Marc,

     Thank you for taking a look at this. I don't seem to have the "template" field on the home landing page. Feel free to take a look at the settings. if you can let me know what has happened with the quote, gallery and other widgets that would be brilliant.   I have sent you an admin login by email .

    Best regards

    Isabel regards 

  •  955
    Marc replied

    Hi Isabel,

    unfortunately I don't have access to the dashboard. Can you check my user role again?

    Best,
    Marc

  • Isabel Lambourne replied

    I'm sorry about that. I have make your role administrator so you should be able to access everything now.

    Best regards

    Isabel

  •  955
    Marc replied

    Hi Isabel,

    the template field is missing because your front page is set to be WooCommerce's shop page. Please assign another page as shop page, which then will be populated with all your products. You don't have to add this page to your menus if you don't want your visitors to go there.

    Best,
    Marc