Okay
  Public Ticket #1684916
Portfolioübersicht Darstellungsfehler
Closed

Comments

  • Yvonne started the conversation

    Hallo liebes Elmastudio-Team,

    ich verwende das Theme Suidobashi für eine Kundenseite und auf den Seiten der Portfoliobeiträge z.B. http://sabrinafritsch.com/portfolio/iv-05-2017/ wird unten die Portfolioübersicht nicht korrekt dargestellt.

    Teilweise werden Bilder angeschnitten und die Abstände über und unter den Bildern stimmen nicht überein. Dann ist die Ansicht nach Neuladen wieder richtig und zwischen den Browsern Safari, Firefox und Chrome ist es mal richtig mal falsch, genauso bei der Mobile-Ansicht. Es scheint auch einen Unterschied zu machen, ob ich im Backend eingeloggt bin, dann ist die Ansicht korrekt, oder nicht, dann tauchen die Fehler auf.

    Könnt ihr mir weiterhelfen, wie ich das Problem lösen kann?

    Vielen Dank und liebe Grüße
    Yvonne



    Attached files:  Bildschirmfoto 2018-08-21 um 21.27.12.png

  •  863
    Marc replied

    Hallo Yvonne,

    ich würde gerne versuchen das Problem nachzustellen. Wenn ich dich richtig verstanden habe, taucht es unabhängig vom Browser, von der Browsergröße (mobil z. B.) und ob du eingeloggt bist oder nicht auf.

    Hast du Änderungen in Form von ergänzendem CSS-Code vorgenommen?

    Eine fonts.css-Datei, die sich im Theme-Ordner befinden soll, kann nicht geladen werden. Ich vermute, du hast direkte Änderungen am Theme-Code vorgenommen. Kannst du mir sagen, was du dort gemacht hast? Könntest du in dem Fall das geänderte Theme einmal irgendwo speichern und durch das Original ersetzen und prüfen, ob das Problem so auch auftritt?

    Kannst du das Problem reproduzieren, wenn du in einem Browser den Cache geleert hast?

    Viele Grüße
    Marc

  •   Yvonne replied privately
  •  863
    Marc replied

    Hallo Yvonne,

    tatsächlich ist es sehr wahrscheinlich, dass das Problem mit dem Lazy-Loading-Plugin zusammenhängt. Für die Anordnung der Bilder ist es für den verwendeten Mechanismus wichtig vorab zu wissen, wie groß diese sind. Durch das Lazy-Loading werden die Bilder jedoch nicht sofort geladen und die Positionierung der Bilder schlägt fehl.

    In deinem CSS lädst du tatsächlich bereits die Schriftart nach. An irgendeiner Stelle jedoch, hast du angegeben eine fonts.css zu laden. Dies führt bei der Darstellung deiner Seite zu keinem Problem, jedoch ist es in jedem Fall besser, diese Stelle zu finden und zu eliminieren um ggf. folgenden Problemen vorzubeugen.

    Mit Hilfe eines FTP- / SSH-Zugangs und einem entsprechenden Client kannst du direkt auf die Dateistruktur deiner WordPress-Installation zugreifen. So kannst du den Inhalt des Theme-Ordners direkt herunterladen und zwischenspeichern. Im Anschluss kannst du den Inhalt löschen und die Original-Theme-Dateien wieder hochladen.

    Dein Webhoster kann dir Zugangsdaten für FTP / SSH und Empfehlungen für entsprechende Client-Programm geben.

    Viele Grüße
    Marc