Okay
  Public Ticket #1312043
Zeitreise theme bug on mobile (iOS 11, Safari, Chrome)
Closed

Comments

  • Volodymyr started the conversation

    Hello,

    1. Zeitreise theme doesn't work properly on Chrome and Safari (iOS 11, iPhone SE). Please see this short screencast - https://streamable.com/61ndg  

    I wasn't just scrolling, I was actually clicking on menu, thumbnails and links but nothing works until it's fully loaded. Zeitreise theme loads after 3-4 minutes not sure why it's so slow, my internet is super fast, other websites load great. You can easily replicate this issue on your mobile - http://themes.elmastudio.de/zeitreise/.

    I also saw theme update here but it didn't fix my site or this current demo site.

    2. Is it possible to remove that preloader (black bar on top)? I feel like it might help as site starts working fine after preloader is gone (3-4 minutes).

    Thank you in advance!

  •  600
    Marc replied

    Hi Volodymyr,

    unfortunately I'm not able to reproduce this behavior. Are you still experiencing this issue with the latest version of iOS?

    2) You'd need to adjust the JavaScript within the theme files and change some CSS code. Please understand that we cannot provide help for individual customizations.

    Best,
    Marc

  •  1
    Frederic replied

    Hi,

    I have the same problem described by Volodymyr.
    It doesn't have anything to do with customizations. It happens on many themes not just Zeitreise, also Hawea and Neubau on iOS 11.0.3.
    This makes the theme unusable, because it takes minutes until it's possible to navigate on the site.
    It seems to be an issue related to the loading bar. I tried disabling the javascript for it, but that made the site unusable on every browser, because no links were clickable.

    Thank you for your help!
    Frederic

  • Volodymyr replied

    Hi @Frederic,

    I thinks this issue is related to iOS. I've preformed a clean install of iOS and it works perfect now. 

    Hope this will help,

    Thanks

  •  600
    Marc replied

    Hi Frederic,

    I'm still not able to reproduce this behavior. Since Volodymyr mentioned it may be a problem with iOS itself, emptying the browser data including its cache may solve the problem. Unfortunately currently the theme demos are running an older version of the themes.

    Best,
    Marc

  •  1
    Frederic replied

    Marc and Volodymyr – thank you for your help!

    I found a workaround that is probably not very elegant, but does the trick for me:

    To the functions.js I added

        $( window ).load( function() {
            
            $('body').addClass('pace-done');      });
    Best,
    Frederic

  • Clint Mamuri replied

    Hi All,

    I'm experiencing the same issue. I tried to apply the code below, but Wordpress won't allow me to save it. It gave me a syntax error.

    Regards,

    Clint

  •  600
    Marc replied
    Hi Clint, please make sure to add the code to your js/functions.js file. Adding it to functions.php will produce a syntax error. Best, Marc
  • Adam replied

    Fredric/Marc

    Experiencing the same issue, where exactly need to put this code into theme functions.js file (add/overwrite existing code)? 

    Any other fixes since last answer?

    thanks in advance.

    Reg

    A

  •  600
    Marc replied

    Hi Adam,

    I think it's best to place it before the closing

    } )( jQuery );

    Best,
    Marc